Error - there are no fields mapped to the output columns

Apr 9, 2010 at 5:08 PM

I've tried the adapter on both SS2005 sp3 and SS2008 sp1.  In both cases I can pull data using the SharePoint List Source.  Also in both cases I can not push data to a SharePoint list using the SharePoint List Destination tool.

When I plug in the URL and the list name (or a list view) into the SharePoint List Destination tool I get the error message:  Error at Data Flow Task [SharePoint List Destination]: There are no fields mapped to the output columns.  Please note that I copy the same URL and list name from the successful tasks that pull from the SharePoint list and write to a SQL Server table.  I'm running this using VMware Workstation 7x, Windows Server 2003 32-bit, and again either SS2005 or SS2008 (and I'm sure I'm using the right version of the adapter on each).

One thing I noticed on the installation on the SS2008 sp1, is that it put the source and destination tool both into the Data Flow Sources area by default.

Any comments appreciated, thanks.


Apr 9, 2010 at 7:13 PM

Problem solved. 

Hitting "refresh" in the lower left hand corner of the "Advanced Editor for SharePoint List Source" corrected the problem, and the target columns of the SharePoint list were automatically displayed.