Can't see Tools in "Choose Toolbox Items" (solved)

May 17, 2010 at 2:30 PM


I've installed the tools, I go to VS2008, select "Choose Toolbox Items" from the toolbox menu and then go to "SSIS DataFlow Items" but I can't see the Sharepoint List tools.  I go to the 100\DTS folder and see the .dll in the Pipeline Components Folder.

I'm running SQL2008 on Win Svr 2008 on a VM.

Any ideas anyone?



May 17, 2010 at 4:34 PM

So, I've installed this on to another SQL2008/Svr2008 system (VM) and it worked straight away.  The server that I need it to work on is our production system and it simply won't show up in the Choose Tools menu, the only difference I can see is that I'm not installing it logged in as Administrator (Domain).  I since uninstalled it and re-installed calling the msi from the cmd line "As Administrator" and still no joy.  If I run BIDS "As Administrator" still no joy.  This is really starting to freak me out and annoy me as I cannot see why I can't see the tools in the tool list.  Just to be clear, this is not just the tool list on the left side of BIDS but also the tool selection list where you can check a box to see which tools you can use in the main tool box area.

I need help and any help greatly appreciated.



Jun 2, 2010 at 10:02 PM

In your SQL 2008 folder, there is a folder like: C:\Program Files\Microsoft SQL Server\100\DTS\PipelineComponents

The highlighted is the important part.  Make sure the two DLLs are in that folder.

It asks for the location when you install the components, so perhaps there is another SQL installation which has a different folder location you should use instead?

Jun 4, 2010 at 4:54 PM

I'm having this same issue; Sharepoint List Destination and Sharepoint List Source do not show up in the SSIS Data Flow Items List under Choose Toolbox Items.

kevinidzi - you mention 2 DLLs, but I only see SharePointListAdapters.dll as having been added. What is the 2nd DLL?

Are there any other suggestions for a resolution?


Jun 4, 2010 at 4:59 PM

My aplologies, I should've posted my answer sooner.

The issue for me was that SQL Server had not been installed to the SQL default directory, although there were the relevant files and folder in the C drive (which confused me) the SQL Server app had been installed on the D drive.  So run the installer again and point it to the correct set of folders, and, if your problem was the same as mine you will be able to see the SharePoint list tool.

Best of luck.


Jun 4, 2010 at 6:04 PM

Thanks MindenMan. Still no luck though. I remain confused re the number of SQL folders. I did not do the initial SQL install and in fact have never done an SQL install which puts me at a disadvantage. I have:

C:\Program Files\Microsoft SQL Server\80
C:\Program Files\Microsoft SQL Server\90
C:\Program Files\Microsoft SQL Server\100
C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL
R:\Microsoft SQL Server\MSSQLL.1\MSSQL (which is where the data files are stored)

I tried the rather inelegant approach of installing the tool to each of these folders (in a DTS subfolder) in turn, with the same results.

Is there any way I can determine with certainty the correct install folder, or any other troubleshooting steps I can take? 



Jun 4, 2010 at 7:27 PM

Disregard last post. It does wonders, when you're using SQL 2005, to install the SQL 2005 version of the tool!