how do i install the 2005 version when i have both 2005 and 2008 locally?

Aug 22, 2011 at 1:07 PM

Hello,

I downloaded the Sharepoint list adapters and installed, works great on 2008.  But I have both the 2005 and 2008 sql server workstation components installed, and it only installed for 2008.  How do I install for 2005 as well?  It didn't seem to give me an option to install for 2005.

Thanks in advance.

Andy

Aug 22, 2011 at 1:14 PM

I should also mention that i used the latest version of the installer, the 8/4 version, which says is for all 3 versions (05/08/R2).

Aug 23, 2011 at 7:48 PM

For sql 2005, I look for the install path at this registry location:

HKLM\Software\Microsoft\Microsoft SQL Server\100\SSIS\Setup, Name = SqlPath

For SQL 2008+, I look for the path here:

HKLM\Software\Microsoft\Microsoft SQL Server\100\SSIS\Setup\DTSPath

You do have SSIS 2005 installed on that machine, correct? If it doesn't detect the reg key, then it will not show up in the installation.  Are you running a 32 bit or 64 bit server?

Aug 24, 2011 at 12:28 AM

Hi, I checked and I don't have that regkey for the 2005 one but i do have the 2008 one.  I added it and it still didn't work, i can still only install the 2008 version.  Yes, i do have both SQL 2005 tools as well as the 2008 tools installed on my PC (32 bit).  I do NOT have the database engine installed.  This is just for development on my laptop for now where I don't have the database engine installed, just Mgt studio/BIDS etc.

Any other thoughts?

Aug 24, 2011 at 12:34 AM

Can i just grab the DLL from somewhere, slap it in the right directory, and GAC it?

Aug 30, 2011 at 6:59 AM

Can you search the registry, starting in HKLM\Software\Microsoft for a string SqlPath (anywhere) or DTSPath and tell me what you find?  It is not finding your SSIS 2005 installation.

Aug 30, 2011 at 4:32 PM

I have SQLPath here:  HKLM\Software\Microsoft\Microsoft SQL Server\100\BIDS\Setup and its value is "c:\Program Files\Microsoft SQL Server\100\Tools\"

I have DTSPath here: HKLM\Software\Microsoft\Microsoft SQL Server\100\SSIS\Setup\DTSPath and it's value is "c:\Program Files\Microsoft SQL Server\100\DTS\"

The problem is they're both SQL 2008.

Sep 6, 2011 at 7:58 PM

I'm having the exact same issue.  The installer will not detect that SQL Server 2005 BIDS is installed.

Manually added HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\100\SSIS\Setup SQLPath=C:\Program Files (x86)\Microsoft SQL Server\90\DTS

Manually added the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\100\SSIS keys to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\90 (with the correct 2005 paths).

Manually added SQLPath=C:\Program Files (x86)\Microsoft SQL Server\90\DTS to the  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\90\SSIS\Setup key

Installer still did not detect 2005 in any case.

I had an older version with the separate 2005 installer.  Installed that and it detected 2005 BIDS and installed correctly.

 

Sep 7, 2011 at 3:03 PM

Sorry I mistyped before, replace 100 with 90 above for SQL 2005.  What edition are you using?

 

Macatter, yes you can, but causes too many issues. I'd rather fix this installer issue.  I'll install to another box and find out if I can repro.

Sep 7, 2011 at 4:55 PM

So perhaps my issue is I don't even have a Setup or SSIS or DTS folder underneath HKLM\Software\Microsoft\Microsoft SQL Server\90

So i tried adding the full folder path (HKLM\Software\Microsoft\Microsoft SQL Server\90\SSIS\Setup) with the string value SqlPath = c:\Program Files\Microsoft SQL Server\90\DTS\, reran setup, still didn't work.

Sep 10, 2011 at 8:10 AM
Edited Sep 10, 2011 at 8:11 AM

OK- I found I was using a key which worked when the engine was installed, but found there was another key I should have been using ... i updated the installer and updated the installers, please try it out. i tested it with a box here that just had bids and verified the before and after.

 

 

Sep 12, 2011 at 4:16 PM

That did the trick!!  It now gave me the option to install for both 2005 and 2008/R2.

Thank you so much.

Sep 12, 2011 at 4:17 PM
That worked kevin, thanks so much!

On Sat, Sep 10, 2011 at 3:10 AM, kevinidzi <notifications@codeplex.com> wrote:

From: kevinidzi

OK- I found I was using a key which worked when the engine was installed, but found there was another key I should have been using ... i updated the installer, please try it out. i tested it with a box here that just had bids and verified the before and after.

The change is in the changeset as for what i modified.

Read the full discussion online.

To add a post to this discussion, reply to this email (SQLSrvIntegrationSrv@discussions.codeplex.com)

To start a new discussion for this project, email SQLSrvIntegrationSrv@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com