Which version of installer required

Sep 13, 2011 at 5:29 AM

Hi,

I'm just trying to install on our developement machine, Window Server 2003 R2 SP2 64 bit, but I'm getting an error:

"This installation package cannot be installed by the Windows Installer service. You must install a Windows service pack that contains a newer version of the Windows Installer service."

I checked msi.dll under windows\system32, and our version is 3.1.4000.4042.

Which version of the installer is required in order to install? I'm guessing 4 or 4.5?

Sep 13, 2011 at 10:53 PM

Ok, solved this problem by installing latest version of windows installer (4.5). I was able to install after this.

Coordinator
Sep 14, 2011 at 7:53 AM

I added the 4.5 requirement to the FAQ page.

http://sqlsrvintegrationsrv.codeplex.com/wikipage?title=SharePoint%20List%20Adapters&referringTitle=Documentation