Upgrading from BIDS 2005 to BIDS 2008

May 11, 2012 at 10:00 PM

I want to upgrade my packages developed under BIDS 2005 to BIDS 2008. The upgrade utility fails because it cannot find the 2005 sharepoint list adapters specified in the packages, although I have the most recent 2008-compatible adapters on the server. If I uninstall the 2008 adapters and install the 2005 adapters it still fails, they don't show in my BIDS 2008 toolbox options so I think BIDS 2008 is just unable to use them. 

How can I upgrade a package using 2005 adapters into BIDS 2008? Help!