SharePoint Not Updating

Oct 14, 2013 at 3:41 PM
I am trying to use the share point adapters for the first time. I have a package that connects to the sharepoint and imports the data into a table--that source connection works fine. Then I compare a date field from the sharepoint data to the same date field in an existing database table, and want to write the date from the other table back to the sharepoint. I have added another dataflow step using a SharePoint destination. The database source only returns two fields, id and this date and connects to those same two fields in the destination. The task executes successfully, shows 302 rows transferred--which is the same amount as when I run the database query manually--but when I look at the sharepoint, nothing is updated. Just for grins I tried writing text to the field and I get a datatype incompatibility error -- so it is detecting the column type from the destination. Why is it not updating?? I have tried it both with and without assigning a view.