The component could not be added to the Data Flow task.

Jun 18, 2009 at 5:19 AM

Please let me know if anyone knows why I am getting the following error when I try to drag and drop SharePoint List source from the toolbox:

fyi:

Installed location: E drive

OS :  Server 2003

VS: 2005

SQL: 2005

===================================

The component could not be added to the Data Flow task.
Please verify that this component is properly installed. (Microsoft Visual Studio)

===================================

The data flow object "Microsoft.Samples.SqlServer.SSIS.SharePointListAdapters.SharePointListSource, SharePointListAdapters, Version=1.2005.0.0, Culture=neutral, PublicKeyToken=933a2c7edf82ac1f" is not installed correctly on this computer. (Microsoft.DataTransformationServices.Design)

------------------------------
For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%u00ae+Visual+Studio%u00ae+2005&ProdVer=8.0.50727.762&EvtSrc=Microsoft.DataTransformationServices.Design.SR&EvtID=PipelineObjectNotInstalled&LinkId=20476

------------------------------
Program Location:

   at Microsoft.DataTransformationServices.Design.DtsBasePackageDesigner.GetPipelineInfo(String creationName, IServiceProvider serviceProvider)
   at Microsoft.DataTransformationServices.Design.DesignUtils.GetNewPipelineComponentObjectName(IDTSComponentMetaDataCollection90 parentCollection, String clsid, IDTSComponentMetaData90 componentMetadata, PipelineComponentInfo& pipelineComponentInfo)
   at Microsoft.DataTransformationServices.Design.PipelineTaskDesigner.AddNewComponent(String clsid, Boolean throwOnError)

 

Coordinator
Jun 22, 2009 at 8:36 PM

Check where you have the installation folder for the SSIS Components and verify it is in the pipeline components (DTS\PipelineComponents) and the GAC.

Apr 15, 2010 at 6:39 PM

We have the same environment set binyamy and are experiencing the same problem.  The components do show in the pipeline components and the GAC.  Any other ideas?

Installed location: E drive

OS :  Server 2003

VS: 2005

SQL: 2005

Any help is appreciated........

May 11, 2010 at 8:43 PM

Same problem here, pls help.

Oct 15, 2010 at 5:26 AM

Yup same problem here my guess is running 32 bit compile of the assemblies. If anyone knows if its possible to register on a BIDS 2005 32 bit. As above the install does GAC registration and the assembly appears in the pipeline components

Any update on this would also be very apprecaited

Thanks

Geoff