SharePoint Adapter for SSIS

May 5, 2016 at 4:40 PM
Hello,

I am using Visual Studio 2013. I downloaded MS Data Tools so that I can create SSIS packages. I also downloaded the SharePoint adapter from here: http://sqlsrvintegrationsrv.codeplex.com/releases/view/17652

I have .Net 3.5 installed (as pre-req). However, when I go to Tools > Choose Toolbox Items, I do not see a tab for SSIS Data Flow Items, as shown in the screenshot.

Can you please assist?
May 5, 2016 at 6:04 PM
For VS 2010 "All components that are installed on the local machine now automatically appear in the new SSIS Toolbox. When you install additional components, right-click inside the toolbox and then click Refresh Toolbox to add the components. The SharePoint List Destination and the SharePoint List Source appeared in the “Common” folder in the SSIS Toolbox when I refreshed the toolbox." I guess 2013 should be the same. The toolbox option is only for BIDS (2008).
Check http://dataqueen.unlimitedviz.com/2011/06/how-to-use-a-sharepoint-list-as-a-data-source-in-your-ssis-package/
May 5, 2016 at 6:35 PM
@mmmarcius

Thanks for your reply. That is the exact same link I used to start using SP as a source. I checked Common folder, I don't see SP as a source :(
I refreshed, rebooted, tried creating a new SSIS project...
May 5, 2016 at 7:42 PM
All,

I was able to resolve this by installing the latest version of the adapter found here:
https://sqlsrvintegrationsrv.codeplex.com/downloads/get/1465238

Thanks!
Marked as answer by MSDN_UZR on 5/5/2016 at 12:42 PM
Jul 6, 2016 at 9:43 AM
Edited Jul 6, 2016 at 10:22 AM
Hi everyone
Unfortunately, it's not work for VS 2015 and SSDT 2015 and SQL 2016
Jul 19, 2016 at 3:06 PM
Make sure you have the right version - 32/64 bit. Also, make sure to search the site for the latest version of the plug-in.
Oct 7, 2016 at 12:48 AM
Edited Oct 7, 2016 at 2:47 AM
Sharepoint Adaptor for SSIS has stopped working for SQL 2016. when I am trying to load, it gives NTLM error message as below
"The HTTP request is unauthorized with client authentication schema 'Negotiate'. The authentication header received from the server was 'NTLM

On download page, there is Sharepoint Adaptor dll file is there (which shows as NTLM fix), however can't find any instructions on what to do with dll file or can't find any msi file to install for that release?