Component upgrade - IF YOU DOWNLOADED 8/3 - READ THIS

Aug 3, 2011 at 10:55 PM

Hi,

I uninstalled old SharePoint adapter and installed new one. Now upon loading the project, I am getting bunch or errors "Error loading package... Couldn't load file or assebly SharePointListAdapter...". I surely understand what the problem is - the old assemble are gone, but have no clue how to fix it... I am new to SSIS... Any suggestion would be greatly appreciated.

Thanks a lot!

 

Coordinator
Aug 4, 2011 at 9:40 AM
Edited Aug 4, 2011 at 9:42 AM

I made a new release to fix this issue,  if it is the same that I saw, related to the installer not copying the files to both program file folders (x86) and x64. 

In addition, there was an issue with the sharepoint connection and how it was named internally. Terribly sorry about this, but if you upgraded yesterday, uninstall that, revert your packages to before yesterday, and reinstall.

SQL 2005 / Denali have been removed - the installer can now install to all x64 Sql Server versions at once.

Kevin

Coordinator
Aug 4, 2011 at 7:43 PM

If you have the prior connection object (either from beta or from the first day), you can open the dtsx file in a text editor and replace SDSSConnection with SPConnection to fix the compat issue.

I did a point release for the installers to fix an issue installing the sql 2005 adapters;  Also added an installer for x86 installations (for desktops/workstations/etc) and fixed a recurrent issue where things wouldn't show up afterwards by restarting the SSIS Service during install. I ran into both of those issues myself after further testing.

Aug 4, 2011 at 8:47 PM

Thank you very much! Will re-install some time later today.

Coordinator
Aug 8, 2011 at 6:18 PM

Any luck yet?

Aug 8, 2011 at 6:20 PM

Everything looks good. Thank you for such an excellent adapter!

Aug 12, 2011 at 10:15 PM

Running Windows XP SP 2, SQL 2005, Visual Studio 2005. Installed and used an earlier version of the SharePoint tools for SSIS. They are awesome. However, I had a problem with CamlQuery (worked one night, but not the next day - vague error message about trying to return too many fields). So I thought I would try the update.

Downloaded the installer for x86. Installed without a problem. Didn't show up in the Tool Selection list.

Saw the Q&A about installing to the same place as the other tools in the Tool Selection list. However, the install package never gives one the option of where to install the package to. I tried all three install options (typical, custom, complete). I also search my computer to see if I could find where the files installed to but no luck. Searched on date modified (ie what was new) and also for the names of the files from inside the archive. Didn't find either so I'm wondering what the install installs. 

Anyway, I have reverted to the older package which is specific for SQL 2005 and which prompts for whether to install for just me or for everyone on the computer. Hopefully this will help you with the install package. Look forward to trying the next upgrade.

Coordinator
Aug 19, 2011 at 8:36 AM

In the installer, if you click "Custom", clicking on the buttons will show a path in the lower right.  I'd be curious what the path it found was, and where you have it installed.  Perhaps I'm reading from the wrong location for SQL2005.  I have an install here, but there are some duplication of reg keys and perhaps I got the wrong one.

Coordinator
Sep 10, 2011 at 8:15 AM

Norm - I recently updated the installer for those that only installed BIDS for SQL 2005, where it would not install the adapters. Please try again.

Sep 11, 2011 at 9:54 PM

Sorry for taking so long to get back to this. I downloaded the new installer for x86, removed the old version from VS2005 tools, tried to uninstall the old version but no option available so logged off my user account, logged on as an admin, installed the new version, realized that the uninstall option was not shown because I was logged on as a user instead of admin (wish they would show all options, just grey out the ones not available - that would provide a tip to those who don't do much installing). Uninstalled old and new versions, rebooted, installed new version, found the tools in the tool selector, added them. Opened an existing package and got 56 errors  

Error      1              Validation error. Load Dashboard Table and Update SharePoint List: DTS.Pipeline: The component metadata for "component "Flag Changed Records for Review" (14714)" could not be upgraded to the newer version of the component. The PerformUpgrade method failed.           F_Pts_Placed_Into_Residential_Care.dtsx           0              0             

 The rest of the errors were basically the same - component metadata.  Maybe I missed something in the migration to the new version?

 So given that this would be a major problem given all the existing packages, I'm going to revert back to the old version. Thanks for looking at it and kudos for fixing the previous problem with the install location and for creating this great tool.

Coordinator
Sep 14, 2011 at 8:56 AM

This is due to a publickey mismatch; now that the components are all built with the same method (instead of the manual way before), they are all the same and it caused some churn the first time around.

I added the fix for this in the FAQ (as well as emailed it to you after verifying with your package)

http://sqlsrvintegrationsrv.codeplex.com/wikipage?title=SharePoint%20List%20Adapters&referringTitle=Documentation