Unable to find SharePointUtility.dll on my computer

Nov 9, 2011 at 2:49 PM

I have installed the SharePoint List Source and Destination adapters on my computer. However, I tried searching for the SharePointUtility.dll on my machine and cannot find it. Where can I find the dll? I really want to be able to use this assembly. Thank you in advance for your help.


Nov 9, 2011 at 4:14 PM

It is in the GAC, so if you are using .Net on a machine where it is installed, you can  reference it.

Nov 9, 2011 at 4:45 PM

Thank you. I found it in the GAC.

I am using VS2010 and when I add a reference, I don't see it listed on the .NET tab in the dialog box that pops up. Is it listed as SharePointUtility? I then tried to browse for it in that dialog box and I browsed to the GAC and that would only display *.dll, *.tlb, *.olb, *.ocx, and *.exe files. How can I select SharePointUtility.dll?

May 31, 2012 at 12:34 PM


I have the same problem, i installed the SharePoint List Adapters but i can't add it in BIDS (menu Project/Add Reference, .Net tab) : it is not listed, i see only SharePointListAdapters (SharePointUtility is in the GAC).

I saw i have to copy SharePointUtility.dll in C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727 directory as explained here but i can't find it anywhere on my computer.


Jun 4, 2012 at 10:09 AM

I finally managed how to get SharePointUtility.dll

  1. Open SharePointListAdapterSetup_x64.msi with 7zip
  2. Extract media1.cab
  3. Open media1.cab with 7zip
  4. Extract SharePointUtilityDLLGACFile and rename it to SharePointUtility.dll

I copied SharePointUtility.dll to (i have an error message about .Net version but it seems ok)

  • C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
  • C:\Windows\Microsoft.NET\Framework64\v2.0.50727

Now i can use SharePointUtility.dll from scripts

Jun 12, 2013 at 2:27 PM
This is an older post, but I am experiencing the same challenge where I see the SharePointUtility in the GAC, but it is not available to add as a reference in my script task. The resolution indicated by cpassuel was not successful for me. I am fairly new to scripting and have been searching for a resolution with no luck. Any guidance is very much appreciated.
Jun 13, 2013 at 5:03 PM
Okay, it looks like I finally was able to add this from the VSTA Project Explorer References.