Component with name "SharePoint List Source 1" and class ID "{2E42D45B-F83C-400F-8D77-61DDE6A7DF29}" could not be created because an error was encountered during its upgrade to the current version.

Oct 12, 2012 at 3:52 PM

When opening an SSIS package using the SharePoint List Source, I get this error

Component with name "SharePoint List Source 1" and class ID "{2E42D45B-F83C-400F-8D77-61DDE6A7DF29}" could not be created because an error was encountered during its upgrade to the current version.

I've installed the same exact version used to create the package on my workstation.

Does anyone have any ideas on how to solve this problem?

Thank you!