Error when deploying in 2012: “Unable to create the type with the name 'SPCRED'”

Jun 20, 2013 at 4:14 PM
Running packages in debug mode works flawlessly. Deploying to SQL bombs with the “Unable to create the type with the name 'SPCRED'” error.

I've uninstalled the official and installed the 2012 beta with the same results. The .dll appears in the PipelineComponents folder, so assuming installation is validated. Has anyone else seen this?

Jul 30, 2013 at 9:20 AM
Hi, I'm encountering this one too.
I successfully deployed after deleting the SharePoint Credential connection managers...
...which probably isn't a helpful solution, hahaha.
I'll let you know if I figure anything else out.
Aug 16, 2013 at 11:48 PM
I'm also encountering this issue. Has anyone been looking further at it?
Jan 27, 2014 at 9:42 PM
I installed the latest version (SharePointListAdaptersSetup-Beta-2012-01-28.msi) on SQL Server 2012. I upgraded all my SSIS packages to 'project deployment mode' and created a SSIS catalog on the server. When I deploy the package to the catalog, I get the same error message. Any ideas why the adapter not working?
Nov 13, 2014 at 5:38 PM
Anyone got an answer to deploy problem?
May 4, 2016 at 8:35 AM
Still no answer to this?
Jan 2 at 4:17 AM
Still looking for any help towards this? I can run the program in Visual Studio 2010 debug mode fine, receiving similar error:
Failed to deploy the project. Fix the problems and try again later.:Unable to create the type with the name 'SPCRED'.

Thoughts: does using EncryptSensitiveDataWithUserKey affect this in any way?

If I were to 'import' the package from the SQL Management Studio into the SSIDB folder rather than deploying FROM development machine in VS2010 to that server it ends up showing the Connection String as NULL. (So instead of giving a failed deployment, it comes over but just doesn't work and fails when attempting to run.) Is there a way to just create this connection string and user name / password manually from the targeted SQL server to bypass this error?

Thanks for any help!
Jan 2 at 10:32 PM
I've gotten this to work. I installed the latest release (SharePointListAdaptersSetup-2016-11-20.msi) link although I am running Server 2012.

Checked the 'complete install' when prompted. Checked under the 'C:\Program Files (x86)\Microsoft SQL Server\110\DTS\PipelineComponents' folder, found that the SharePointListAdapters.dll had installed there correctly. Deployed from Visual Studio 2010 on development machine (as package model) to the SQL Server. Ran it as a job using a proxy with credentials that had permissions on both the SharePoint list and the SQL server.

tldr; use latest version on 2012 server, should deploy okay but check it installed to the correct folder.