Strange Issue with The SharePointListAdapters in BIDS - Library Not Registred

May 25, 2009 at 7:32 PM
Edited May 26, 2009 at 4:53 PM


I've been using this adapter for a couple month now and it is pretty amazing.  I've try to install the SharePointListAdapters on a win 2003 server (64-bit + SQL 2005 with service pack 2)  and I can't get the source adapter nor the destination adapter to work on this server.  For an instance, when I add the Sharepoint List Source, if I edit it, I only have ID, Name and Description available not the rest.  As for the SharePoint List Destination, I get this error message Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).

I've try uninstalling and reinstalling the solution and I still have that issue.  Any idea how I can resolve this issue?


May 26, 2009 at 1:10 PM

Also, I wanted to add that I tried to manually registerwith this command:

%windir%\syswow64\regsvr32 "%ProgramFiles(x86)%\Microsoft SQL Server\90\PipelineComponents\SharePointListAdapters.dll

And I get this error:

C:\Program Files (x86)\Microsoft SQL Server\90\DTS\PipelineComponents\SharePointListAdapters.dll was loaded, but the DllRegisterServer entry point was not found.

This file can not be registered.

May 27, 2009 at 7:41 PM

The DLLs are not COM, so you can't use RegSvr32.  Check that the .Net framework 3.5 is on your target machine, that's all I can think of offhand.

Is the package failing at runtime or designtime?  If you create the package on your dev machine, and just have it execute on the target server, does it work? 

May 27, 2009 at 8:14 PM

Hello Kevin,

Thanks for replying.  To answer your question, .Net framework 3.5 is installed on the server and the package is failing at design time.  It works perfectly on my workstation.  Even if I create a dummy package with only the Sharepoint List Source I get that error (on the server). 

As for executing the package on the target machine I get the "Error: SSIS Error Code DTS_E_PRODUCTLEVELTOLOW. The product level is insufficient for component" "SharePoint List Source" (1) error as seen in this discussion we had back in February: Trouble running the SSIS package on SQL server.  We currently run many other packages every day on this server without any issues.  This is the only package using the Sharepoint Adapter. Anything else I've develop on the server in BIDS also works (without the Sharepoint Adapter). 

From all that it seems clear that Integration service is working properly on the server and everything needed (SQL service pack 2 and .Net framework 3.5) are installed.

I also tried uninstalling and reinstalling the MSI with no luck.  I'm puzzled.. and I need to put this on an automatic job scheduling asap.

Jun 8, 2009 at 4:47 PM

I haven't had any update on this issue.  Can someone help me? 

Jun 22, 2009 at 9:42 PM

Are you sure you installed the SSIS Adapter for SQL 2005 and not SQL 2008?  What product version of SQL do you have on the machine (Standard, Enterprise, etc)?    

I saw this link which may be related: